San Jose Data Center is having degraded smartlist performance
Incident Report for Marketo
Resolved
This incident has been resolved.
Posted 20 days ago. Oct 03, 2017 - 11:27 PDT
Investigating
San Jose Data Center is having degraded smartlist performance
Posted 20 days ago. Oct 03, 2017 - 10:30 PDT