Some customers in AB are experiencing delays with email sending
Incident Report for Marketo
Resolved
This incident has been resolved.
Posted about 1 month ago. May 19, 2017 - 09:43 PDT
Investigating
We are investigating why some customers are experiencing some issues with email delays.
Posted about 1 month ago. May 19, 2017 - 08:37 PDT