List Import service for Ashburn Datacenter is experiencing degraded performance
Incident Report for Marketo
Resolved
Services have been restored.
Posted 15 days ago. Sep 09, 2017 - 22:09 PDT
Investigating
We are currently investigating the cause of this issue and working on a prompt resolution.
Posted 16 days ago. Sep 08, 2017 - 15:25 PDT